首页 > 精选文章 > PHP > 正文

MagickWand for PHP linux INSTA

作者:屈海超 (http://www.haichaoqu.com)
创造价值、分享价值、以博客会友! 愿和你一起探讨电子商务、互联网广告和网络营销。

ImageMagick是功能强大的服务器端图片处理工具,比GD强大多了。很多PHP的网站随着应用的广泛,开始用到ImageMagick,虽然其配置并不复杂,但如果几个需要注意得地方没有注意,恐怕就要浪费很多时间和精力了。本文意在帮这些人,尽量一次就安装配置成功。

本文参考了国内外大量的资料。包括ImageMagick官方文档。

 

第一步,下载编译ImageMagick.

注意要点,1、版本,版本要和下面的Magickwand兼容,否则编译中会出错。2,加入–enable-shared –with-modules 选项,否则可能最后MagickWand for PHP无法编译成功。

tar -jxvf ImageMagick-6.3.3-10.tar.bz2

cd ImageMagick-6.3.3

./configure –enable-shared –enable-lzw –without-perl –with-modules

make

make install

 编译完成

第二步,安装 Magickwand for PHP

tar -jxvf MagickWandForPHP-1.0.4.tar.bz2

cd MagickWandForPHP-1.0.4

 /usr/local/bin/phpize  (没有PHPIZE,需要首先安装PHP,然后才能进行这一步。另外,这个工具也在php-devel包里面。)

./configure –with-php-config=/usr/local/bin/php-config –enable-shared –with-magickwand=/usr/local

(请注意–enable-shared 参数,别漏掉,否则可能编译出的.so无法加载)

make

 这时候,MagickWandForPHP-1.0.4中会产生modules文件夹,里面是我们需要的magickwand.so

 复制它到php.ini中配置的 extension_dir 中。

然后修改php.ini,增加extension=magickwand.so

重启apache

这时候.phpinfo()页面里面,应该有了magickwand 选项。

本人经过2次尝试,最终成功。

 

其他问题:

如果MagickWand 执行./configure 时,出现checking for MagickSetImageTicksPerSecond in -lWand… NO的错误,可能是您现在安装了两个版本的ImageMagick,且默认的版本低于ImageMagick-6.3.3

可以用Magick-config –version命令查看其版本。

通常是系统安装了rpm包,解决方法是卸载掉libImageMagick包:

rpm -qa | grep ‘ImageMagick’

然后rpm -e libImageMagick….

  • 上一篇:行业网站发展呈现四大趋势
  • 下一篇:什么是歇后语?